Powerschool - Overall Connectivity Issues - All PS platforms
Incident Report for Enterprise Support - Alabama
Resolved
There have been no further reports of issues with connectivity. Based on analysis with PowerSchool's providers, we have determined that traffic was reaching a threshold within one of our network providers which caused the degraded performance issue. The issue had been identified and updates have been made to address the issue moving forward.
Posted Apr 01, 2024 - 12:52 CDT
Update
Overall connectivity has improved throughout the day yesterday and today. The PowerSchool team is still working to identify the problem and devise a solution.

This alert will stay open until a solution is found.
Posted Mar 05, 2024 - 12:49 CST
Investigating
PowerSchool is currently investigating a widespread connectivity issue potentially impacting all PowerSchool Platforms, including PS SIS.
Posted Mar 04, 2024 - 09:32 CST
This incident affected: PowerSchool SIS (SIS).