Analytics & Insights - Student Plans

Incident Report for Enterprise Support - Alabama

Resolved

Student Plans issue is resolved.
Posted Aug 10, 2026 - 12:21 CDT

Monitoring

Fix has been implemented & Post-fix monitoring is underway to ensure the issue is fully resolved and no regressions occur.
Posted Aug 10, 2026 - 10:19 CDT

Identified

The issue has been identified and our team is working to implement a fix.
Posted Aug 07, 2026 - 18:52 CDT

Investigating

We're currently investigating an issue affecting ALSDE districts where district contacts can access Student Plans, but are only able to see a very limited number of plans rather than the full set they should have access to. Our team is actively working on identifying the root cause and will share updates as soon as we have more information. Thank you for your patience.
Posted Aug 07, 2026 - 15:56 CDT
This incident affected: Analytics & Insights.