PowereSchool SIS Slow/Not Responding
Incident Report for Enterprise Support - Alabama
Resolved
No further reports of slowness or outages have been reported.
Posted May 13, 2024 - 12:30 CDT
Monitoring
Performance should be stable once again and issues have been resolved. If you are still experiencing issues, please contact support and we will prioritize your issue. Thank you!
Posted Apr 29, 2024 - 09:17 CDT
Investigating
We are aware and currently investigating an issues in which districts are reporting seeing slowness or outage of their PowerSchool SIS. An update will be added to this status page as soon as a resolution has been determined. Thank you for your patience.
Posted Apr 29, 2024 - 08:38 CDT
This incident affected: PowerSchool SIS (SIS).