PowerSchool Support Case Creation

Incident Report for Enterprise Support - Alabama

Resolved

This has been resolved. Cases can be entered via Community.
Posted Apr 21, 2025 - 12:23 CDT

Investigating

There is currently an issue with creating cases via Community. The PowerSchool team is aware and working on a resolution. This page will be updated accordingly. Chat and phones can be used for support assistance.
Posted Apr 21, 2025 - 08:54 CDT
This incident affected: PowerSchool SIS (SIS, PS SIS API, PS SIS ODS, PS SIS Enterprise Controller, PS SIS Locator/ETS, PS SIS Cross LEA Enrollment/Grades Passback, Powerschool SIS PowerPack), Unified Insights (Unified Insights Dashboard, Unified Insights Data Warehouse Sync), and Schoology, Enrollment, Special Programs, Performance Matters Analytics, Professional Learning, TalentEd Applicant Tracking Enterprise.