PowerSchool SIS - Service Interruption

Incident Report for Enterprise Support - Alabama

Update

PowerSchool is continuing to investigate the issue. Your SIS should be available at this time but if you are still experiencing a disruption, please update your support case.
Posted Aug 01, 2025 - 15:16 CDT

Investigating

PowerSchool is aware of an issue where the SIS may be down. We are currently investigating the issue and will provide updates when available. If you are experiencing an outage, please submit a ticket to the SIS support team.
Posted Aug 01, 2025 - 13:37 CDT
This incident affects: PowerSchool SIS (SIS).