PowerSchool Special Programs - Unable to Finalize Documents

Incident Report for Enterprise Support - Alabama

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 15:37 CST

Monitoring

A fix has been implemented and we are monitoring. If you are still experiencing issues, please contact support.
Posted Dec 01, 2025 - 18:27 CST

Identified

The team has identified the issue and is working on a solution.
Posted Dec 01, 2025 - 12:06 CST

Investigating

PowerSchool is investigating an issue with finalizing documents in Special Programs. Our team is working on the issue and will post updates on the status page as more details become available.
Posted Dec 01, 2025 - 09:56 CST
This incident affected: Special Programs.