Cross LEA Grade Viewer

Incident Report for Enterprise Support - Alabama

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 10:46 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2026 - 09:43 CST

Investigating

PowerSchool is aware of an issue where the Cross LEA Grade Viewer is not available. Our teams are working on the issue and updates will be posted as they become available.
Posted Mar 04, 2026 - 09:36 CST
This incident affected: PowerSchool SIS (PS SIS Cross LEA Enrollment/Grades Passback).