PowerSchool Support Number Not Connecting Callers to Support Team
Incident Report for Enterprise Support - Alabama
Resolved
This issue has been resolved.
Posted Mar 25, 2024 - 09:38 CDT
Monitoring
The issue with the phone system has been identified and corrected and PowerSchool Support will continue monitoring.
Posted Mar 18, 2024 - 19:15 CDT
Investigating
PowerSchool has been notified that when AL districts call the AL support number and enter their support ID, the district is receiving a message that their ID is not found. This has been replicated by our Support Team and we are engaging with our IT team to determine and resolve the cause.

If a district needs immediate support assistance, the Community Web Portal and Chat support are still available or optionally, AL districts can leverage the general PS Support number - 866-434-6276.
Posted Mar 18, 2024 - 09:31 CDT
This incident affected: PowerSchool SIS (SIS, PS SIS API, PS SIS ODS, PS SIS Enterprise Controller, PS SIS Enterprise Transfer Server, PS SIS Cross LEA Enrollment/Grades Passback), Unified Insights (Unified Insights Dashboard, Unified Insights Data Warehouse Sync), and Schoology, Enrollment, Special Programs, Performance Matters Analytics, Professional Learning, TalentEd Applicant Tracking Enterprise.