PowerSchool Special Programs - Special Education History Profile

Incident Report for Enterprise Support - Alabama

Identified

PowerSchool Special Programs has identified the cause impacting security groups from importing Special Education History profile with the student envelope. In the meantime, please use the 'Assume System Admin Role' to complete student transfers.
Posted Mar 24, 2025 - 07:39 CDT

Investigating

PowerSchool Special Programs is aware of an issue impacting security groups from importing Special Education History profile with the student envelope. We are investigating and will keep the status page updated with new information.
Posted Mar 14, 2025 - 13:56 CDT
This incident affects: Special Programs.