PowerSchool SIS - Incident attendance drawer cannot be edited from Student record

Incident Report for Enterprise Support - Alabama

Resolved

This issue has been resolved with the 25.5.1.1 release which was applied to production over the weekend. If you are still experiencing any issues, please reach out to support.
Posted Jun 30, 2025 - 09:11 CDT

Identified

The fix for this issue will not be available until this summer. If you are having issues with the workaround, please update your support ticket.
Posted May 05, 2025 - 12:53 CDT

Investigating

PowerSchool Support is aware of an issue where the window to edit attendance related actions in an incident is grayed out and cannot be edited.

The workaround is to use the All Incidents page to modify the Attendance Related Action tied to the Incident Record.

If you are experiencing this issue, please enter a support case.
Posted Apr 14, 2025 - 10:54 CDT
This incident affected: PowerSchool SIS (SIS).