PowerSchool Special Programs - IEP Alert

Incident Report for Enterprise Support - Alabama

Resolved

This incident has been resolved.
Posted Jun 24, 2026 - 07:58 CDT

Monitoring

Please disregard the recent message regarding expired IEPs. PowerSchool recently deployed a new feature, and it is currently not taking next year's IEP information into account when generating these notifications. As a result, some alerts may have been sent in error.
Moving forward, this feature is intended to notify staff when there is an actual gap in services or when an IEP requires attention. We are actively working with PowerSchool to address the issue and appreciate your patience.
Posted May 21, 2026 - 11:33 CDT
This incident affected: Special Programs.