PowerSchool Student Locator Unavailable

Incident Report for Enterprise Support - Alabama

Monitoring

A fix has been implemented and we are monitoring the results. If you experience the issue again, please let support know.
Posted Aug 13, 2025 - 15:07 CDT

Investigating

PowerSchool is aware that the student locator is unavailable. We are working to restore services and will post updates as they become available. If you are experiencing the issue, please enter a case with support.
Posted Aug 13, 2025 - 09:46 CDT
This incident affects: PowerSchool SIS (PS SIS Locator/ETS).