PowerSchool SIS - Slow Performance

Incident Report for Enterprise Support - Alabama

Investigating

We are aware that slower performance issues are back today, including issues loading or navigating the PowerSchool SIS. The team is investigating thoroughly and will update this status page with all new information.
Posted May 08, 2026 - 09:13 CDT

Monitoring

A fix has been implemented and we are monitoring the results. If you are still having issues, please update your case or submit one if you have not.
Posted May 07, 2026 - 15:24 CDT

Investigating

PowerSchool is aware of an issue where users may experience slower-than-normal performance, including delays when loading or navigating the SIS. Our team is actively investigating and will provide updates on our status page.
Posted May 06, 2026 - 08:03 CDT
This incident affects: PowerSchool SIS (SIS).