Powerschool SIS - Historical Grades Transfer May Overwrite Course Numbers
Incident Report for Enterprise Support - Alabama
Update
The next round of audits have returned good results and PowerSchool is not seeing recurrence of the overwrite issue. We will continue to monitor and audit.
Posted Apr 24, 2024 - 13:17 CDT
Update
The next round of audits have returned good results and PowerSchool is not seeing recurrence of the overwrite issue. We will continue to monitor and audit.
Posted Apr 16, 2024 - 11:13 CDT
Update
No new reports of issues have come in. Weekly audits have been clear. We will continue auditing for the next several weeks.
Posted Apr 15, 2024 - 11:08 CDT
Update
Subsequent data fixes have been applied and daily audits from last week show that there have been no further overwrites. Audits will continue weekly, and PS will continue monitoring.
Posted Apr 08, 2024 - 10:00 CDT
Monitoring
The newest release of SIS Core 24.3 contained additional work to prevent course number changes. Round of Day 1 audits show no records updated since application of the release. Transfer Course Number function has been re-enabled and the PowerSchool Support team has started working on data correction steps. No actions are needed by the districts at this time.
Posted Apr 01, 2024 - 12:51 CDT
Update
Powerschool will be deploying SIS core 24.3 to the production servers this upcoming weekend and re-enabling the course number transfers. Once this is completed, the Support team will be re-applying the data correction scripts to fix any records overwritten by the ETS transfer process. No action is needed by districts to have this done.
Posted Mar 26, 2024 - 13:54 CDT
Identified
The subsequent transfer overwrite issue fix is being tested by ALSDE for production release. Once approved, we will schedule maintenance to apply this update, re-enable historical course number transfers, and then re-apply data correction scripts to districts. There is no action needed from the districts as this data correction will be applied to all AL districts.
Posted Mar 25, 2024 - 09:40 CDT
Update
Subsequent Post Update and data fix auditing by PowerSchool Support showed that the course numbers may still be getting overwritten on student records transfers. Out of an abundance of caution, we are re-disabling the course number transfer on student transfers.

PowerSchool is working towards a permanent solution.
Posted Mar 13, 2024 - 16:45 CDT
Update
PowerSchool has completed conducting data correction steps on this issue.

The fixes released to help address this have tightened the platform logic around the Student Historical Grades Transfers, however, PowerSchool is still trying to find a root cause for the issue.

Over the next few weeks, districts should doublecheck student records transfers around historical course numbers. If it is noted that the course numbers were updated by the ETS Server process within the last few weeks, please open a support case immediately, so Support can capture logging on the change event.
Posted Mar 11, 2024 - 10:59 CDT
Update
There is no action for districts to take on the data cleanup portion of this fix. The Support team are processing the data cleanup scripts on every district. Course number transfers have already been re-enabled.
Posted Mar 04, 2024 - 11:30 CST
Update
PS SIS updates that address this issue have been applied and the historical course number transfer function has been re-enabled. Support will be starting a data correction project this week to correct overwrites caused by the ETS process.
Posted Mar 04, 2024 - 10:22 CST
Monitoring
The Student Records Transfer Course Number function will be re-enabled when this weekend's update is applied.

Data cleanup efforts to correct overwrites will start next week. No action is needed by customers on this data cleanup effort. This is being done in the background to correct any course numbers potentially overwritten by the ETS server processes.
Posted Mar 01, 2024 - 08:48 CST
Identified
A resolution to this issue will be deployed with PS SIS 24.2, which will be tested by ALSDE next week. Once approved and applied to Production, PowerSchool Support will be deploying scripts to correct the previous overwrites. No cases are needed for this action.

Once completed and verified, course numbers on records transfers will be re-enabled.
Posted Feb 23, 2024 - 16:35 CST
Investigating
PowerSchool is investigating an issue that has been reported where, after historical grades are imported in with a student transfer, the same process is updating some records with invalid course numbers. This has been reported to the PowerSchool Development team to be reviewed, resolved, and for data correction measures to be developed and deployed.

Until further notice, the Course Number transfer function will be disabled on the ETS server plugin. Once the issue has been determined, corrected, and data corrections measures deployed, this will be re-enabled by Support.

If, while reviewing historical grades that have been transferred, and find records that were additionally altered by the ETS process, please log a case with support with the following information:
Impacted Student Number
Date and time of transfer
Course number transferred
Date and time of subsequent ETS alteration
What course number it was changed to
Report that this is a condition reported to PS SIS Development in PSF-91880

Support will gather any relevant logs required and will assist with any needed immediate correction needed to ensure that data is corrected for transcripts.
Posted Jan 29, 2024 - 16:23 CST
This incident affects: PowerSchool SIS (PS SIS Enterprise Transfer Server).