Analytics & Insights: Dashboard data overnight refresh delayed

Incident Report for Enterprise Support - Alabama

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 23:41 CDT

Identified

The root cause of the build delays has been identified. Builds are still running and will continue to run throughout the rest of today.
Posted Mar 25, 2025 - 11:36 CDT

Update

We are continuing to investigate this issue.
Posted Mar 25, 2025 - 11:15 CDT

Investigating

We identified a data loading issue last night impacting overnight builds for the majority of the districts.

Builds are still running and we'll update the status page once all builds are completed.
Posted Mar 25, 2025 - 09:43 CDT
This incident affected: Unified Insights (Unified Insights Dashboard).