Support Phone Line Unavailable

Incident Report for Enterprise Support - Alabama

Resolved

This has been resolved and the phone line is accessible.
Posted Jun 10, 2025 - 11:41 CDT

Identified

PowerSchool is aware of an issue with the support phone line being unavailable. If you need support assistance, please submit a case via PowerSchool Community.
Posted Jun 10, 2025 - 10:32 CDT
This incident affected: PowerSchool SIS (SIS, PS SIS API, PS SIS ODS, PS SIS Enterprise Controller, PS SIS Locator/ETS, PS SIS Cross LEA Enrollment/Grades Passback, Powerschool SIS PowerPack), Unified Insights (Unified Insights Dashboard, Unified Insights Data Warehouse Sync), and Schoology, Enrollment, Special Programs, Performance Matters Analytics, Professional Learning, TalentEd Applicant Tracking Enterprise.