PowerSchool Special Programs - Error when logging in

Incident Report for Enterprise Support - Alabama

Monitoring

Users should not longer experience an error when logging into Special Programs. The team is still working to identify the issue. If you are still having issues logging in, please contact support.
Posted May 23, 2025 - 07:37 CDT

Investigating

The PowerSchool team is aware that users may be experiencing the following error message when attempting to log in to Special Programs, "An error occurred while attempting to log in." We are investigating the issue and will post an update on the status page. If you are experiencing the issue, please enter a support case.
Posted May 22, 2025 - 15:35 CDT
This incident affects: Special Programs.