Unified Insights - MTSS Production: Student plans not loading
Incident Report for Enterprise Support - Alabama
Resolved
Testing has been completed and student plans has been re-enabled in production. The application is now available to users again. We will continue to monitor the environment to ensure availability and high performance.
Posted Apr 16, 2024 - 13:55 CDT
Monitoring
Please note that the hotfix has been deployed to production. Based on testing we have confirmed that the Student Plans app is much more responsive with the latest enhancements, however, the Student Plans app is still unavailable in production at this time while we complete additional testing.

Based on these tests we will be able to confirm if Student Plans will be re-enabled in production. We will keep this page updated with the latest status.
Posted Apr 16, 2024 - 09:34 CDT
Update
A hotfix to help with the MTSS Student Plans performance issues will be released tonight during the ongoing approved maintenance window (starting at 8pm CST lasting up to 3 hours). At this time the MTSS Student Plans application is not available to districts (Unified Insights and MTSS Interventions is still available).

After the hotfix is deployed tonight we will assess if the enhancements improved performance enough to re-enable the Student Plans app for users.
Posted Apr 15, 2024 - 11:59 CDT
Identified
At this time we have turned off MTSS Student Plans access so that we can isolate the performance issue. General site performance improved after turning it off. We plan to keep MTSS Student Plans turned off while the team is working on performance enhancements so that the general site is not impacted. We plan to iteratively make changes to the site to fix the performance issues which will help us resolve the full issue faster and is a less risky plan overall. We are planning to have an iterative hot fix ready for the first identified change to be released on Monday during the approved nightly maintenance window.
Posted Apr 12, 2024 - 15:14 CDT
Investigating
We've received reports that MTSS Students Plans is slow to respond. Please note that PowerSchool is aware of it and an investigation is in progress.
Posted Apr 11, 2024 - 11:32 CDT
Monitoring
Changes have been made in Prod and we believe our updates will resolve the performance issues. We will continue to monitor. Please let us know if any districts continue to experience slowness.
Posted Apr 10, 2024 - 09:26 CDT
Update
PowerSchool is continuing to investigate the issue with Unified Insights where student plans are not loading as expected (keeps spinning).
Posted Apr 08, 2024 - 10:28 CDT
Investigating
PowerSchool is investigating an issue with Unified Insights where student plans are not loading as expected (keeps spinning). The team is looking into it currently and will work on a fix at the earliest possible.
Posted Apr 04, 2024 - 15:24 CDT
This incident affected: Unified Insights (Unified Insights Dashboard).