Analytics & Insights: Student Plans

Incident Report for Enterprise Support - Alabama

Monitoring

All Monday morning (5/19/2025) tests indicates that systems are operating normally. The PowerSchool team continues to actively monitor the impact of this weekend’s changes.
Posted May 19, 2025 - 07:14 CDT

Identified

We’ve received reports of latency when saving student plans. If you encounter latency, please DO NOT refresh the browser; wait for 2 minutes for the work to save. PowerSchool will perform maintenance over the weekend to address these concerns
Posted May 16, 2025 - 15:00 CDT
This incident affects: Unified Insights (Unified Insights Dashboard).